[Gelöst] Firefox startet nicht mehr auf openSUSE Leap 42.1

Nach einem Update und Neustart meines openSUSE Leap 42.1 ließ sich Mozilla Firefox nicht mehr starten.

Der Aufruf per Konsole ergab diese Fehlermeldung:

# firefox

XPCOMGlueLoad error for file /usr/lib64/firefox/libxul.so:
/usr/lib64/firefox/libxul.so: undefined symbol: PR_DuplicateEnvironment
Couldn't load XPCOM.

Ich vermutete einen Fehler im Firefox-Profil und versuchte es mit dem ProfilManager.

# firefox --ProfileManager

Das führte zur gleichen Fehlermeldung.

Also deaktivierte ich mein Firefox-Profil.

# mv ~/.mozilla/firefox/0e9eigme.default ~/.mozilla/firefox/0e9eigme.disabled

Gleiches Ergebnis.

Profil wieder aktiviert.

# mv ~/.mozilla/firefox/0e9eigme.disabled ~/.mozilla/firefox/0e9eigme.default

Neuinstallation von Firefox.

# zypper in -f MozillaFirefox

Gleiches Ergebnis.

Die Lösung

# zypper in -f mozilla-nspr
Loading repository data...
Reading installed packages...


Forcing installation of 'mozilla-nspr-4.12-10.1.x86_64'
from repository 'openSUSE-Leap-42.1-Update-OSS'.
Resolving package dependencies...

The following package is going to be reinstalled:
  mozilla-nspr

1 package to reinstall.
Overall download size: 113,0 KiB. Already cached: 0 B.
No additional space will be used or
freed after the operation.
Continue? [y/n/? shows all options] (y): y
[...]

Bingo.

Firefox startet direkt anschließend fehlerfrei.

Ein Kommentar

Hinterlasse eine Antwort

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind markiert *